首页 帮助中心 听云Server 支持列表
名称 要求
JVM
  • Oracle Hotspot JVM for Linux, Solaris, Windows, OSX 6 - 8
  • Apple Hotspot JVM for OSX 6
  • IBM JVM for Linux 6 - 8
  • OpenJDK 6 - 8
Application servers
  • ColdFusion 10
  • Glassfish 3.x - 4.x
  • InforSuite AS 9(中创)
  • JBoss 4.0.5 - 7.x
  • JBoss EAP 6.x
  • Jetty 6.x - 9.x
  • Netty 3.5 - 3.9
  • Resin 3.1.9 - 4.0
  • Tomcat 5.5.x - 8.5.x
  • TomEE 1.5
  • TongWeb 5 - 6(东方通)
  • WebLogic 10.3.3 - 12.1
  • WebSphere 7.0 - 8.5.5
  • WildFly 8.0.x - 8.1.x
Frameworks
  • Apusic
  • EJB2
  • EJB3
  • Grails 1.3.7 - 2.3.x
  • JSF (Java Server Faces)
  • Mule 3
  • Oracle Service Bus 11
  • Play 1.2.2 - 1.2.4
  • Play 2.0.3 - 2.3.x
  • Spring 3.x - 4.x
  • Spring Boot 1.5.x
  • Struts 2.0.x - 2.5.x
  • Jfinal 3.2
JDBC drivers
  • Apache Derby derbyclient 10.9.1.0
  • Apache Derby 10.2.2.0 , 10.10.1.1 , 10.11.1.1 , 10.13.1.1
  • PostgreSql 9.3-1104-jdbc4 , 9.4.1208 ,42.0.0 , 42.1.4
  • IBM DB2 db2jcc(1.4.2) , db2jcc4(10.1,11.1)
  • Microsoft SQL Server sqljdbc4(4.0) , jtds(1.2 - 1.3.1)
  • MySQL mysql-connector-java(3.0.x ~ 6.0.x)
  • Oracle ojdbc5(11.1.x ~ 11.2.x) , ojdbc5(11.1.x ~ 11.2.x) , ojdbc7(12.1.0.2.0) , classes12(10g) , ojdbc14(10.2.0.4.0)
  • 达梦 Dm7JdbcDriver17
  • C3p0 0.9.5.2
  • Dbcp commons-dbcp(1.4)
  • Proxool 0.8.3
  • Hibernate hib3.0.xernate-core(4.2.2.Final)
  • Mybatis mybatis(3.3.0)
  • Spring-Jdbc 3.2.17.RELEASE
  • Druid 1.0.4 , 1.0.5 ,1.0.15 ,1.0.25
NoSQLs
  • Memcached(spymemcached 2.10.x ~ 2.12.x , xmemcached 1.4.3+ , 2.0.x ~ 2.1.x , memcached-client 3.0.x)
  • MongoDB 2.6.x ~ 2.14.x ,3.0.x ~ 3.3.x
  • Jedis jedis(2.7.x ~ 2.9.x) , spring-data-redis(1.2.x ~ 1.7.x)
RPC Services
  • Java.net (HttpURLConnection) JDK1.6 , JDk1.7 , JDK1.8
  • HttpClient commons-httpclient(3.x) , httpclient(4.x)
  • AsyncHttpClient async-http-client(1.6.x - 1.9.x)
  • Axis 1.4
  • Apache Axis2 1.6.x - 1.7.x
  • Apache CXF 2.1.x - 3.1.x
  • Spring WS 2.1.x - 2.4.x
  • Spring WS 2.0.0+
  • Java JAX-WS 2.0.x-2.2.x
  • Java JAX-RS 3.0.x
  • Jersey 2.0+ , jersey-core(1.0.3 - 1.19.x)
  • Resteasy 2.0.x-3.0.x
  • Apache Thrift 0.5 , 0.8.0 , 0.9.3
  • Alibaba Dubbo 2.5.3,2.4.10 , 2.6.6
  • Enterprise Java Beans (EJB) 2.0 , 3.0
  • Mina 2.0.9
  • org.asynchttpclient 2.0.32
  • okHttp 2.4.0
  • grpc 1.0.1 , 1.6.1
  • Twitter Finagle 6.22.0
MQ
  • RabbitMQ 3.5.x - 4.x
  • ActiveMQ activemq-core(5.3.x-5.7.x) , activemq-client(3.5.x-3.6.x)
  • Kafka 0.8
  • JMS and Spring-JMS 1.1
Others
  • Quartz Job Scheduler 1.8.3 - 2.2.x
  • Scala 2.9 - 2.10 async tracking
  • Solr 1.4.0 - 4.0
  • Log4j 1.2.x , log4j-core(2.0.x-2.10.x)
  • Logback 0.9.x-1.2.x