首页 帮助中心 听云Server 支持列表
听云Server
名称 要求
JVM
  • Oracle Hotspot JVM for Linux, Solaris, Windows, OSX 6 - 8
  • Apple Hotspot JVM for OSX 6
  • IBM JVM for Linux 6 - 7
Application servers
  • ColdFusion 10
  • Glassfish 3.0 - 4.0
  • InforSuite AS 9(中创)
  • JBoss 4.0.5 - 7.x
  • JBoss EAP 6.x
  • Jetty 6.1 - 9.1
  • Netty 3.5 - 3.9
  • Resin 3.1.9 - 4.0
  • Tomcat 5.5 - 8
  • TomEE 1.5
  • TongWeb 5 - 6(东方通)
  • WebLogic 10.3.3 - 12.1
  • WebSphere 7.0 - 8.5.5
  • WildFly 8
Frameworks
  • Apusic
  • EJB2
  • EJB3
  • Grails 1.3.7 - 2.3.x
  • JSF (Java Server Faces)
  • Mule 3
  • Oracle Service Bus 11
  • Play 1.2.2 - 1.2.4
  • Play 2.0.3 - 2.3.x
  • Spring 3.x - 4.x
  • Struts 2
JDBC drivers
  • DB2
  • Dameng
  • Informix
  • jTDS open source JDBC 3.0 type 4 driver for Microsoft SQL Server (6.5 up to 2008) and Sybase ASE
  • MySQL
  • Oracle ojdbc14, ojdbc5, ojdbc6
  • Postgres postgressql-8.4-701.jdbc3, 9.0, 9.1
  • SQLServer sqljdbc4
  • Generic support for other JDBC drivers
NoSQLs
  • Memcached(spymemcached 2.*, xmemcached 1.4.3)
  • MongoDB 2.12.0
  • Jedis 2.2.0
RPC Services
  • Apache Axis2 1.5+
  • Apache CXF 2.7.0+
  • Dubbo 2.4.0+
  • Grpc 1.0.1, 1.6.1
  • Thrift Client 0.8.0+
  • XmlRpc Client
  • Mina 2.0.9
  • Spring WS 2.0.0+
  • Java JAX-WS
  • Java JAX-RS (REST)
  • Jersey 2.0+ (REST)
  • Resteasy 2.2+ (REST)
MQ
  • RabbitMQ 3.5 (AMQP and JMS)
  • ActiveMQ
  • Kafka 0.8
Others
  • HttpClient 3.0.1 - 4.3.0
  • java.net (HttpURLConnection)
  • JMS 1.1 and Spring-JMS
  • JMX
  • JSP - Java Server Pages 2.0 - 2.2
  • Quartz Job Scheduler 1.8.3 - 2.2.x
  • Scala 2.9 - 2.10 async tracking
  • Solr 1.4.0 - 4.0